Talk:Triple Boot via BootCamp Ubuntu

From Wiki
Jump to: navigation, search

Trouble with installing Lilo

Using Ubuntu 6.06, I found that my computer (a MacBook, not Pro) did not complain when it came time to install GRUB, and this not only failed to boot Linux but I suddenly couldn't boot Windows as well. Furthermore, I had the problem that my network connection (Ethernet, not Wi-Fi) worked but when I chrooted onto my hard drive, it didn't work. I wondered how I could remove GRUB and install LILO without being able to apt-get anything. The solution was:

After the installation, in the chrooted terminal:

apt-get remove grub
rm -rf /boot             # so lilo can write there without weirdness

Then go to a non-chrooted terminal and download the lilo and linux-kernel-headers .deb files. A good way to do this is to open Synaptic, select the packages, and download them (but don't install). This will cache them on your hard drive. Move the packages onto your hard drive:

cp lilo* /mnt/ubuntu/    # from wherever you downloaded the lilo .deb
cp linux* /mnt/ubuntu/   # ditto

Go back to your chrooted terminal:

dpkg -i lilo*
dpkg -i linux*

Then you have to copy a few files out of the Desktop CD's /boot to your hard drive so the symlinks in the /etc/lilo.conf file point to the correct place. From the non-chrooted terminal:

cp /boot/vmlinuz* /mnt/ubuntu/boot/
cp /boot/initrd* /mnt/ubuntu/boot/

You should then be able to follow the rest of the article, from writing the /etc/lilo.conf file onwards. You may have to run /sbin/lilo -P fix as described there; I had to run it twice before the program didn't execute fatally. Good luck!


I've been messing around with edgy, to see if I can get it to install. Following my instructions, I ended up with a message, saying nothing bootable could be found, please insert something bootable and press any key. Windows and OS X still worked fine though. I may have messed up somewhere, executed a command from the wrong terminal (I had to run the apt-gets in the chroot, as when they were run in the ordinary console, the command "lilo" was not available from the chroot.

lilo also had to be silenced with -P ignore-table, as there was a CHS/LBA mismatch (that may have been releated to something I did however, I think I may have run parted in the wrong console when resetting boot flags).

If anyone more knowledgeable than myself wants to take a look, feel free.

I've now completed the edgy eft guide, if anyone has any problems leave a note at my user page, but I'm afraid my linux skills are not the best. If anyone finds better ways to do stuff, feel free to edit. Themysteriousx 20:17, 7 November 2006 (EST)

I followed the instructions exactly for Edgy. When I try to boot into the new Edgy partition the screen goes black and the fans spin really fast. I don't see any text. I have a first generation MBP.

Update: I have it working now (sort of). I added the line append="lpj=8000000 noapci" to /etc/lilo.conf and that allowed me to boot into the normal Edgy kernel. I also found that restarting and booting Edgy failed a lot more than turning off and turning on again.

I also compiled the 2.6.18-5 vanilla kernel since it contains a lot more Macbook support and a lot more core duo optimisations. I am running this at the moment without appending any lines to the /etc/lilo.conf.

Have a look at here for information on setting kernel compile settings. I just used make-kpkg to compile the kernel. I also compiled the daily snapshot version of the madwifi drivers since the release version doesn't have support for the wireless chipset in my MBP. silver, 20th Dec.

What is the difference between a chooted terminal and a none chrooted terminal?

What is the difference between a chooted ternimal and a none chrooted terminal. In all the tutorials I have read no one explained the difference .This seams to be the area where people are messing up. I need know the difference before I try.