Talk:Triple Boot via BootCamp

From Wiki
Jump to: navigation, search


Anything posted here that asks a question that SHOULD be posted in the forum WILL be deleted, and any subsequent reverts will be reverted.

A description on how to remove the extra partitions if you no longer want triple booting would perhaps be helpful...

il serait interssant de traduire la page en divers langues

page translation in multilanguage ?

babgond 17 April 2006 (CDT)

First off, IANAAO (I Am Not An Apple Owner).

Has anyone tried installing grub to the linux boot partition (instead of the MBR)?

In order to still have access to the on-disk utilities in my ThinkPad, I cannot modify the IBM installed MBR.

So, instead I do the following:

  1. Reload the IBM software
  2. Shrink the NTFS partition (hda1)
  3. Install linux normally (/boot to hda2)
  4. Install grub to first sector of hda2
  5. Make hda2 bootable.

Don't know if any of this applies to the Boot Camp camp. But, I'd be glad to try it if someone sends me an Intel Mac!

The Dave 17:11, 15 April 2006 (CDT)

WRT to the question above, I can confirm that grub does not work. I tried installing it in every place I could think of before giving up and moving to lilo.

The reasons why grub cannot be used are already mentioned in the "science of chainloading" section, however it will help you to understand why if you look at the bootstrap section of the grub manual and the GPT table entry on wikipedia. In a nutshell: The "safe unused sectors" meantioned in the grub manual where it wants to install stage 1.5 are already in use by gpt. Grub throws up errors during installation, and will consequently hang if you try to boot using it. That said, in theory stage 1.5 is "optional", however without it you'd need to bypass the filesystem and access the stage 2 code raw. Much more hassle than it is worth.

LILO and BootCamp

I am currently using lilo in MBR in combination with Boot Camp. It did not work instantly, but after trying to boot with XOM once BootCamp detected the bootable MBR even though it is LILO and no Windows MBR.

Using Lilo in the MBR is much more convenient when upgrading to a new kernel, because you just have to run lilo again after copying the kernel into the boot partition.

There is no need to edit the boot.ini from Windows. Windows is started through LILO.

My Setup for LILO:

 boot = /dev/sda
 map = /boot/.map
 install = /boot/boot-menu.b 
 delay = 10
 vga = normal
 image = /boot/bzImage.2.6.16-gentoo-r2-imac1
       root = /dev/sda5
       label = Gentoo
       read-only # read-only for checking
       append="acpi=force libata.atapi_enabled=1 init=/linuxrc root=/dev/sda5 gpt"
 other = /dev/sda3
       label = Windows
       table = /dev/sda

Swap partition

If you use the filesystem type "Swap", diskutil resizeVolume will create a linux swap partition.

Yes, it will create a swap partition. However, check out the limitations meantioned in the partitioning notes. If you add a swap partition you end up with 5 primary partitions... too many for MBR record to hold. Thus, only the first 4 partitions will be visable to legacy OS'es.

Now, I know from numerious repartition experiments performed on my drive that the windows partition must be the last mbr partition on the drive. I'm not so sure if it must be the GPT partition as well, although I suspect this to be the case. If it is the case, then the swap partition will bugger up the windows installion no matter where it is placed. If I'm wrong then you could theoretically place a swap partition as the 5th primary partition, however in this case you will most likely need to build a custom kernel, one that uses legacy booting, and GPT partitioning.

Anyone want to try it?

What to do if Windows installer doesn't reformat the target partition for you

While attempting to manually partition my disk for tripple boot (J-HFS+, J-HFS+, FAT-32), I ran into a situation where the windows installer would see the target partition as type "FAT-32" instead of "unknown", and so would not offer to reformat it prior to installation. Consequently, the windows partition was not bootable, and I received "Disk error" any time I tried to boot from it.

One solution is to nuke the first bit of the windows partition with zeros, destroying the filesystem metadata. This causes the Windows installer to see the partition as type "unknown", and it will then dutifuly offer to reformat it for you. This can be accomplished with the following, where rdisk0s3 is your windows partition (typically this would be either rdisk0s3 or rdisk0s4)

dd if=/dev/zero of=/dev/rdisk0s4 bs=1m count=100

Another solution that worked for me is to specify an invalid filesystem type for the windows partition when using diskutil resizeVolume. This allocates the space, but the MBR doesn't flag it as FAT-32, so the Windows installer again offers to reformat it at install time.

After installing Debian, XP says AUTOCHK.EXE not found, skipping AUTOCHECK and reboots

I had this problem following the instructions here. It is caused by the system ID of the Windows partition: gptsync gives it the id EF "EFI System (FAT)" and I managed XP to work again by changing the system ID with fdisk, after running gptsync and lilo.

# fdisk /dev/sda

choose t, then 4 (that changes the system ID of the 4th partition, the Windows one) and finally set the ID to c "W95 FAT32 (LBA)". Then press w to write the table and exit. XP should now boot properly. The only issue is that, using this method, GPT and MBR are not synchronized (they have different system IDs for the Windows partition) but in this way Windows, Linux and Mac OS X run perfectly.

dual boot

Is there any way to dual boot windows (xp) and linux (ubuntu) without installing osx? All guides (dual and tripple boot) I have come across requiers that you begin with installing osx. .